Select Page

ERROR: Shopify Style [CHECKOUT] – Payment processing failed. Please retry.

Home Forums Support ERROR: Shopify Style [CHECKOUT] – Payment processing failed. Please retry.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • Helpful
    Up
    0
    Down
    Not Helpful

    Hello Divi Engine.

    I just purchased this plugin to assist with handling the checkout page process with greater control over design and style.

    However, I’ve run several tests using Stripe and determined that the Shopify Style [CHECKOUT] returns a:
    Payment processing failed. Please retry.

    I’ve gone through several of the other Checkout Styles and Shopify Style is the only one that fails (of those I tested below).

    • Multi-Step: PASSED/PROCESSING to Order Received Page
    • Accordion: PASSED/PROCESSING to Order Received Page
    • One Page: Multi-Step: PASSED/PROCESSING to Order Received Page

    I’m most interested in the Shopify style and I’m going to take a best guess and say that there is something in the Shopify style code that is causing the issue based on 3 other styles work as intended.

    Can you please look into and let me know what needs to happen.
    Thank you.

    Warm regards,
    Mark Regynski

    Helpful
    Up
    0
    Down
    Not Helpful

    Hello Divi Engine team,

    Got exactly the same trouble. Stripe shows this error message: Stripe Payment Request live mode requires SSL.

    What a pity because this design is just great and perfect.

    Thanks for your help on this trouble!

    Best regards,

    Cyrielle

    Helpful
    Up
    1
    Down
    Not Helpful

    Hi Mark, Hi Peter,

    I made the following change and it works: (Woocommerce version 4 changes a little the advanced setting available):
    – go to /www/wp-content/plugins/woocommerce/includes
    – open class-wc-https.php
    – change woocommerce_force_ssl_checkout from false to true (before it was in options.php and it was a yes or no)
    – you can find it in this line “if ( ! is_ssl() && ( is_checkout() || is_account_page() || apply_filters( ‘woocommerce_force_ssl_checkout’, true ) ) ) {”

    Then, reload the file on your ftp and the magic should happen!

    Enjoy

    Bertrand

    Helpful
    Up
    0
    Down
    Not Helpful

    Hi All,

    I have not seen this issue before.

    It seems to be an issue with the SSL, but not sure why it would be different for the Shopify style.

    Is your site HTTPS and have a certificate?

    Thanks Bertrand for this solution, it is interesting – I think there is a setting in WooCommerce for this so you do not need to edit code.

    Can you go to WooCommerce > Settings > Advanced and check the box ‘Secure checkout’ – see below

    Secure Checkout Setting

    Does this work?

    Helpful
    Up
    0
    Down
    Not Helpful

    Hi DiviEngine team,

    Hum…weird because i didn’t have this part in my advanced menu. Here the screenshot: snipboard.io/5rwRzv.jpg That’s the reason why i went into the file 😀

    Woocommerce version is 4.1.1…the latest, no?

    @Mark what about you?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.